Service and speed issues across multiple destinations

Incident Report for Travel Roam Status

Update

Deployment of the final fix was completed by our connectivity provider last night.

Initial tests are showing the fix has worked and field testing with select partners is ongoing.

Newly sold eSIMs are still being routed to the alternative provider. Once we have completed comprehensive testing, we will start the phased process of notifying partners and moving traffic back to a stable Profile 1.
Posted Jun 25, 2025 - 10:44 UTC

Monitoring

Over the weekend, our team and connectivity provider identified the root causes for the issues with Profile 1 (ICCID prefix 89444).

Our provider deployed two fixes over the weekend, with a final fix planned for deployment overnight tonight after further testing. Initial results show significant improvements in stability and performance. The final fix targets issues when customers move between network towers and cell sites.

We will not re-route any traffic until all fixes are deployed and a period of extended internal and partner testing and monitoring is completed. This is to ensure connectivity, coverage, and speeds meet expectations.

Until then, connectivity will continue to be routed to the alternative profiles with no impact on your rates and billing. We aim to move traffic back to Profile 1 by the end of June.

We will provide a further update tomorrow morning following deployment of the final fix. In the meantime, please continue to share feedback in the usual way.
Posted Jun 23, 2025 - 15:21 UTC

Update

The team continues investigating issues with Profile 1 over the weekend.

As per yesterday's update, most countries have been re-routed to new network providers, and we see successful orders and traffic.
We are monitoring the situation closely and have an extended team working over the weekend. Please continue to log tickets and faults as usual.

Partial refunds
If you have issued a replacement eSIM on a started bundle, please record the ICCIDs and share them with us to review and complete partial refunds early next week.
Posted Jun 21, 2025 - 08:12 UTC

Update

Despite further network changes to Profile 1 (ICCID Prefix 89444), we still see some speed and connectivity issues.

The countries listed below have now been rerouted to an alternative provider. An email with additional information and details has been sent to all partners.

There is no change to your pricing. Your rates remain exactly as agreed.

New eSIMs
Will automatically be provisioned on the alternative IMSI profile. You do not need to take any action, and there is no change to your rates or cost.

Top-Ups to existing eSIMs
Please issue a new eSIM if a customer requires a new top-up - the API will automatically offer a new eSIM from the alternative IMSI profile if a top-up is requested

Existing eSIMs sold and live with customers
We expect to recover as we make further changes. If customers report issues, please advise them to toggle aeroplane mode. If the problem persists, issue a new eSIM and log the case with Travelroam Support for tracking.

Partial refunds
Where you have issued a replacement eSIM on a started bundle, please keep a record of the ICCIDs and share with us to review and complete partial refunds early next week.

Our engineers, suppliers, and vendors will continue to work around the clock, including through the weekend, with updates to follow.

Aaland Islands
Australia
Austria
Bangladesh
Belgium
Bulgaria
Canada
Canary Islands
Colombia
Costa Rica
Croatia
Czech Republic
Denmark
Egypt
El Salvador
Estonia
Europe Lite
Finland
France
Germany
Gibraltar
Greece
Guernsey
Hawaii
Hungary
Iceland
Ireland
Israel
Italy
Jersey
Latvia
Liechtenstein
Lithuania
Luxembourg
Malta
Morocco
Netherlands
Norway
Oman
Pakistan
Poland
Portugal
Romania
Saudi Arabia
Slovakia
Slovenia
Spain
Sweden
Switzerland
Thailand
Tunisia
United Arab Emirates
United States of America
Vatican City
VietNam
Posted Jun 20, 2025 - 19:48 UTC

Update

Service and speed issues are ongoing and we are continuing to investigate these in collaboration with our connectivity provider.

Our connectivity provider has made some network changes and we are currently testing and monitoring traffic following these.

While we continue to work towards a resolution, we are implementing contingency measures to reroute affected destinations to alternate providers in order to minimise the impact over the weekend. An email with further details will follow.
Posted Jun 20, 2025 - 13:35 UTC

Investigating

We are receiving reports of intermittent service and speed issues on eSIMs with ICCID prefix 89444.

We are working closely with our new connectivity provider to investigate this and implement a contingency plan to minimise impact over the weekend. We will provide a further update later today.

Thank you for all of the examples already shared, these have been used with our new connectivity provider to escalate the investigation.
Posted Jun 20, 2025 - 10:59 UTC
This incident affects: eSIM Connectivity.