After a period of monitoring, we see that platforms are stable, both ours and our provider's. Connectivity on Profiles 2 and 3 has stabilised; please ask users to retry their connections.
A number of stuck orders from during the incident are irretrievable. We'll cancel and refund these tomorrow during business hours and provide a list of those affected.
We apologise for any disruption experienced.
Posted Aug 27, 2026 - 05:03 UTC
Update
Our provider has reported that API services are now recovering.
They report that connectivity services may also be degraded.
Our provider is continuing to work on restoring full service. We will provide further updates as we receive them
Posted Aug 26, 2026 - 13:50 UTC
Investigating
We have noticed some degradation in APIs relating to Profiles 2 and 3. Connectivity is unaffected: eSIMs already active on these Profiles are working normally.
We're still assessing the scale of this and are working with our provider to understand the cause.