Following on from the update shared on Thursday April 17, we can confirm that no new orders have been impacted by this incident.
We are continuing to monitor this situation and our Customer Success team will continue to work with affected partners through the course of this week.
If you have questions or need support, please reach out to Support as normal.
Kind regards, Travelroam
Posted Apr 22, 2025 - 15:25 UTC
Update
Following on from the update shared yesterday, we are still actively monitoring this situation and have found no new impacted orders after April 9 2025.
Our Customer Success team has begun contacting affected partners and will continue over the coming days and into the next working week.
As it is the Easter bank holiday weekend in the UK from Friday April 18 to Monday April 21, we have provisioned additional resource to continue monitoring this.
If you have any further questions, please feel free to reach out as normal.
Kind regards, Travelroam
Posted Apr 17, 2025 - 16:39 UTC
Monitoring
With partners help and support we identified an issue with a number of eSIMs with install issues. These eSIMs are marked on the API as status ‘Unavailable’.
The issue was fixed on April 09 2025 and all subsequent sales are unaffected.
We have now identified the impacted eSIMs sold before April 09 and our Customer Success team will be reaching out to impacted partners with a resolution and our Support team will update relevant tickets.
Below is a summary of how eSIMs may be impacted:
-eSIMs with the status ‘Unavailable’ that have been successfully installed can be topped-up will continue to work as expected. However, they cannot be re-installed to a new device. Users will require a new eSIM in this instance.
Our sincerest apologies for the inconvenience caused to you and your customers and thank you for your patience while we investigated this matter. Please do contact us if you require additional information or support.
Kind regards, Travelroam
Posted Apr 16, 2025 - 17:52 UTC
Update
We’re still actively investigating eSIMs that have been incorrectly assigned the Unavailable status as a matter of priority and will provide further details as they become available.
We’d also like to thank those partners who have already shared their examples via a Support ticket. Please continue to share these.
Kind regards, Travelroam
Posted Apr 15, 2025 - 14:43 UTC
Identified
Following our previous post about eSIMs with an ‘Unavailable’ status we wanted to share a further update.
Below is some guidance on what to do if you or your customers encounter one of the affected eSIMs:
-If you see Unavailable and Not Installed eSIMs in your account, we recommend not allowing top ups and issuing new eSIMs instead.
-If your customer sees an 'eSIM Cannot be Added' message during activation, we recommend issuing a new eSIM.
-Unavailable eSIMs that are already installed on a device should not be impacted and can be used as normal, however we recommend not allowing top ups on these specific eSIMs to prevent any future issues.
eSIMs purchased after April 10 2025 are NOT affected. We’re actively investigating the scale of this issue and will provide further updates daily here on our Status page.
If you do encounter this issue, please raise a support ticket with the affected ICCIDs.